2010-3Q: PROVISIONING: Provision Now support for MikroTik routerboards

Up to now SIMPLer provided support for auto-provisioning Motorola Canopy and Ubiquity Nanostations. This has now been extended to include support for MikroTik routerboards which are acting as CPE devices. From a SIMPLer perspective the process for provisioning a MikroTik routerboard is identical to other equipment types. In particular the customer account must be setup as follows:

    • The customer status must be "waiting for install"
    • There must be no IP addresses or equipment assigned to the customer account
    • The Gateway, Traffic Shaping Bucket, Auto-Prov IP type and Auto-Prov NAT fields should be set to appropriate values on the customer details network tab.

The steps required by the installer are as follows:

    • Use wibox / telnet / ssh to configure the routerborard CPE as follows
      • Configure the wireless settings to connect to the correct AP - the exact commands needed will depend on the AP (e.g. SSID, frequency, security settings, etc).
      • Set the router identity to the customer nickname
        • /system identity set name="shorty1"
      • Set the installer IP on the wlan1 interface
        • /ip address set interface=wlan1 address=10.11.1.199
    • Enable API access on the routerboard
        • /ip service set api disabled=no
    • Provision the CPE in SIMPLer by going to tools and selecting "Provision Now".

The following routerborard firmware versions have been tested - others may also work:

  • 3.30
  • 4.5
  • 4.10

Notes:

    • It is not necessary to enable SNMP as this will be done during provisioning.
    • If a password is set on the CPE, please ensure that it is entered in the "Equipment Password" field in the "network details" section of the WISP settings in SIMPLer (user -> Modify WISP). The provisioning process will first try to access the CPE with username "admin" and a blank password, and then using username "admin" and the password from the "Equipment Password" field.
    • The CPE tool (accessed by clicking the "P" or "S" on the customer details Equipment details will display information live from the device. NAT can be enabled/disabled from here also.
    • Similar to other equipment types, a password is NOT set on the device during provisioning. If a password has been set by the installer, it will remain set. At the end of the provisioning process the installer should verify the settings, and then if necessary set a password.